¡Hola Forastero!

Pareces nuevo por aquí. Si quieres participar, ¡pulsa uno de estos botones!

He querido volver al 0.4.1 pero me quedo atascado

Hola a todos. Ya se que este foro esta apagado desde hace tiempo pero he querido retomar mi aparatito, un hmr-600w que tenia el firwm original actualizado al c757HP_SR10E. Hace tiempo ya tuve funcionando el mismo con el mod 0.4.1 completo pero me canse no recuerdo porque motivo y ahora quisiera volver a instalarlo todo. La cuestion es que lo he formateado con el firm original que os comento y evidentemente ahora no iba nada del 0.4.1. Posteriormente he vuelto a instalar por el metodo interruptor trasero instalo el firm modificado0.4.1 para el hmr-600w y con el scrip en sistema sale el menu open-hmr. Le doy a actualizar aplicaciones y sale cartel que no encuentra nada. Deduzco que por no estar actualizado al nuevo servidor. La pregunta que es donde me pierdo, donde pongo el nuevo servidor para poder instalar el IMS 5.3. y de ahi en adelante? o de que manera tengo que hacer para instalar el IMS 5.3 y todo lo demas que complementan el Firmware de Chucky. Gracias y espero podais orientarme. Un saludo.

Comentarios

  • Igual que al otro compañero, aunque los archivos siguen estando disponibles, los enlaces han cambiado, y por lo tanto los scripts desde el aparato no funcionan.

    hay que descargarse la parte que te interese y editar las url por las nuevas, y luego ejecutar desde el cubo por telnet.

  • gracias chucky por contestar. Seria muy explicado el explicar como hacer esto? yo principalmente seria instalar el ims 5.3 y tener servidor dlna en el cubo. Hay algun post donde se den estos pasos que indicas? me he hartado de leer y no he visto la forma. gracias.

  • edited enero 30

    Si solo quieres el servidor dlna. entonces sigue el hilo del compañero

    http://hmr600.com/discussion/902/instalacion-mediatomb-en-openhmr-mod-v-0-4-1-tras-cierre-code-google

  • Hola chuky. Perdona por tardar en responder. He seguido los pasos del enlace del compañero y despues de varias pruebas estoy en un punto que no avanzo. He modificado el archivo de instalacion de mediatomb con notepad++ para no tener problemas. Despues desde telnet le doy la orden de install pero me da error de hash del archivo y de crear los directorios correspondientes.

    https://imgur.com/i8C7ioe

    despues hice una nueva prueba por si asi ayudaba a la descarga y era copiar el archivo mediatomb_v1.tar.bz2 ya descargado desde la web de descargas y colocandolo en la carpeta /tmp/hdd/livepause donde se hubiera descargado . Despues lanzaba de la misma forma el install y me soltaba el telnet lo siguiente:

    https://imgur.com/xgXxjRi

    Como puedes ver, va mejor pero veo que sigue sin poder crear los directorios.
    Alguna solucion? Se me escapa algo?
    Me podrias enviar un enlace con el archivo de instalacion ya modificado con la nueva direccion de descarga y asi salir de dudas? gracias por tu paciencia. un saludo.

  • En el primer caso, parece que la descarga del archivo no se ha realizado de forma correcta, luego como el hash es incorrecto, te da el error. además te dice que no se ha podido crear el directorio /usr/local/etc/openhmr, que si tee fijas es el mismo error del segundo caso, no se pueden crear carpetas en /usr/local/etc

    Da la impresión de que no puedes escribir en esa carpeta.

    Ten en cuenta que no tienes el firm 0.4.1, con lo que el firm es distinto y pueden faltar archivos.

    Por ejemplo el Archivo openHMR.cfg en /usr/local/etc/

    /usr/local/etc/openHMR.cfg

    Ese archivo es necesario para la configuración de las variables del archivo, aunque por lo que leo influye mas en la parte de descarga y verificación, por si acaso añádelo. Es solo un archivo de texto editado con notepad++ con las propiedades:
    encoding - UTF sin BOM
    edit - EOL conversión - convertir a formato UNIX

    El archivo es el siguiente:

    # Configuración openHMR
    
    # OPENHMR_HOMEDIR [PATH del directorio]
    OPENHMR_HOMEDIR="/tmp/hdd/root/openhmr"
    
    # OPENHMR_DOWNLOADS_DIR [PATH del directorio]
    OPENHMR_DOWNLOADS_DIR="/tmp/hdd/livepause"
    

    Y luego salvarlo con el nombre
    openHMR.cfg

    y moverlo a la carpeta /usr/local/etc/

    No existe el archivo modificado, no lo tengo y por lo tanto no hay enlace.

    Prueba a ver

  • Gracias Calimocho por tu ayuda tambien. He metido tu archivo ya modificado del install mediatomb sustituyendo al mio pero con el telnet me lanza el mismo error, sigue dando error de hash y no pudiendo crear las carpetas necesarias. Chucky, si que tengo el firm 4.1 instalado y puedo acceder al servicio ims donde actualmente me sale la base donde esta el mig jukebox, la cajita de herramientas, el AEMET y Youtube. En herramientas solo esta ajustado en activo lo imprescindible. Comprobado que en la ruta que me indicabas esta el archivo openHMR.cfg con varias configuraciones, muchas mas que las que me indicabas en el recuadro amarillo, que son los estados actuales del menu de herramientas. Algo debe estar bloqueando el poder crear carpetas. Volvi a formatear el HD pero sigue igual despues de empezar todo el proceso de nuevo de instalacion. Seria posible introducir en actualizaciones del sistema la ruta nueva donde descargar el ims 5.3? es que que yo sepa no he instalado nada mas que el firmw 0.4.1 y nada mas, ni menus ni actualizaciones de ims. Esta todo virgen y solo con el firmw 0.4.1. Gracias

  • En principio te deberías hacer estas preguntas ¿Hay espacio libre en /usr/local/etc? ¿Está montado /usr/local/etc en modo R/W o en modo sólo lectura? ¿Acepta mkdir que le pases el -p o hay que crear carpeta a carpeta? La primera te la debería responder el comando df, la segunda con el comando mount ejecutándolo sin argumentos y la tercera deberás averiguarla con el propio mkdir ¿Existe el directorio /usr/local/ect/openhmr? Si no es así, prueba el comando mkdir /usr/local/etc/openhmr

    Saludos.

  • edited febrero 9

    Hola Calimocho. Ante todo perdonad mi ignorancia con respecto a las partes tecnicas de este firmware. He seguido tus pasos para averiguar las cuestiones que me planteas por lo que ya dentro de la ruta /usr/local/etc le pongo el comando df y despues del resultado le meto el mount y estos son los resultados:

    image

    Con esos resultados no sabria decirte si hay espacio disponible en la particion a pesar de estar el disco de 1tb formateado, o si esta montado en R/W o solo lectura.
    El directorio openhmr no existe dentro de la ruta /usr/local/etc, comprobado con el filezilla

    image

    Como puedes ver, hay varios directorios y archivos pero no el openhmr y me es imposible crearlo con el filezilla pues depues de crear al actualizar desaparece. Tampoco me deja el Filezilla cambiar los permisos de escritura de la raiz usr ni de local por lo que protegido debe de estar.

    Pasado el comando mkdir /usr/local/etc/openhmr me lanza lo siguiente:

    image

    Acabo de hacer una nueva prueba y es crear con mkdir en la misma ruta, un directorio llamado openbank y si que me lo ha creado y tengo acceso desde filezilla, lo intento despues cambiar de nombre a openhmr y me sigue diciendo que existe el openhmr. Pero si no apare ce¡¡¡¡ donde esta???. Esto es un expediente X o algo se me escapa. Gracias y un saludo.

  • edited febrero 9

    ¿Es posible que exista un fichero openhmr en /usr/local/etc? Si fuera así, ésa sería la razón ya que no puede crearse un directorio con un nombre si ya existe un fichero en esa ruta con ese nombre. La solución sería eliminarlo o renombrarlo, bien con el filezilla bien con el comando adecuado:

    (eliminar)
    rm /usr/local/etc/openhmr

    (renombrar a viejo_openhmr, por ejemplo)
    mv /usr/local/etc/openhmr /usr/local/etc/viejo_openhmr

    Saludos.

    PD: Por cierto, Sí tienes espacio libre (9% usado, 14936 bloques disponibles) y /usr/local/etc está montado en modo R/W (r/w, noatime).

  • edited febrero 10

    Hola. De una forma inesperada he conseguido instalarlo. Probe primeramente a instalar ims 5.3 que no lo tenia. Lo hice de la manera que hacia antes con el mediatomb, copiando el archivo ya descargado en livepause y luego lanzar la instalacion por telnet con su install tambien copiado en /hdd. Modifique la ruta de descarga pero aun asi lo mejor era que estuviera ya descargado. Una vez instalado aparecio el famoso directorio /openhmr. Asi que repeti el proceso con el mediatomb y voila¡¡¡ quedo instalado definitivamente. Por lo visto, ya no funciona nada de las apli del ims 5.3 pero bueno al menos tengo dlna con el mediatomb. Espero os sirva mi esperiencia y muchas gracias por vuestra ayuda.

  • Supongo que al final sí que deberías tener un fichero openhmr en /usr/local/etc. La ventaja del instalador del IMS 5.3 es que comprueba esa posibilidad y, si lo encuentra, ya se encarga él mismo de renombrarlo.

    Ahora mismo quizá te encuentres un archivo con el nombre openhmr.old-FECHA además del directorio openhmr recién creado.

    Saludos.

  • Sorprendentemente no, sigue el directorio openhmr solo y ninguno con extension old. He ahi la muestra.
    image

    Ahora estoy guerreando con el bit torrent, donde pongo las descargas y activado el servicio desde ajuste pero las descargas o no empiezan o descargan a muy poca velocidad aun teniendo 50 Mb fibra, y se descanectan solas y se quedan a 0 y no vuelven a reiniciar. Un caos, vosotros me direis, pero creo que ese tema no se quedo muy pulido por lo poco que he leido. Un saludo y gracias por todo nuevamente.

  • Si usas el cliente que traen los firms originales de serie, esos eran los problemas que tenia.

    Al final se instalo transsmision como cliente de torrent en nuestros firms, es muy rápido, pero satura mucho el procesador y es muy propenso a colgar el chisme.

    No se encontró nada decente definitivo.

  • Una pregunta compañeros. Seria posible quitar el user y password del hmr-600w. Actualmente es hmb -- hmbuser pero me da problemas para usarlo como acceso de almacenamiento desde un servidor domestico que tengo en casa por lo que para usarlo como respaldo seria ideal que no tuviera password. Donde podria cambiarlo o desactivarlo? porque no encuentro donde. Tendria que editar algun archivo? Gracias de nuevo. Saludos.

  • No quiero ser aventurado, pero creo recordar que SMB no tiene contraseña.

Accede o Regístrate para comentar.