¡Hola Forastero!

Pareces nuevo por aquí. Si quieres participar, ¡pulsa uno de estos botones!

Dudas: Puerto serie y actualización del firmware Woxter i-Cube 35 X-Div XP REC

edited febrero 2016 en Dudas
Hola,

Llevo un tiempo con errores al reproducir películas desde el reproductor ( Pantalla bloqueada, reinicios). Tengo el último firmware oficial de Woxter.

Por telnet he visto que tiene una CPU  Realtek Venus   MIPS 4KEc V6.4

He probado el firmware de HMR-700 pero siguen habiendo cortes y congelaciones.

Lo he abierto y he visto que tiene una placa
HMR-700 y los controles frontales son de un HMR-35.


Tiene un puerto UART  con :
1 MASA
2 UART_RX0
3 UART_TX0
4 UART_RX1
5 UART_TX1
6 VCC 3,3v


Me intentado conectar al puerto UART con un sitecom cn-104v4002
http://www.sitecomlearningcentre.com/es/products/cn-104v4002/usb-to-serial-cable-0-6m/downloads

Este monta un chip Pl2303.

He conectado:

UART CONECTOR DB9
GND PIN5 (GND)
UART0_TX0 PIN2 (RXD)
UART0_RX0 PIN3 (TXD)

Me conectado con putty.
Speed: 115200
Data bists: 8
Parity: None
Flow Control: None

He apagado el multimedia y lo he encendido y sólo aparecen caracteres raros. No aparece el dmesg del sistema ni el bootloader.
He probado también sin usar un conversor, en Linux y en Windows XP y tengo el mismo problema.
También he probado ha utilizar el UART1 y girar los cables, comprobar si se tocaban los cables pero no.

Alguna ayuda?
También me gustaría saber si puedo ponerle un firmware alternativo para que funcione.
Sal2

Comentarios

  • edited febrero 2016
    Para el tema de la UART puedes variar los datos de conexión a ver si funcionara con otros. Yo lo primero que intentaría sería bajar la velocidad. También podrías comprobar si conectando 3.3V+ al pin correspondiente cambiaba algo.

    Lo de un firmware alternativo para que funcione es complicado. Si el reproductor está bien físicamente el firmware oficial debería de funcionar correctamente (como antes). Así que reinstalando el oficial debería bastar si la causa del mal funcionamiento es un firmware corrupto. Aunque, teniendo en cuenta el chip tan antiguo (creo que el RTD1281 o RTD1261) es normal que ya esté en las últimas (como la mayoría de los HMR-600 que son un pelín más modernos y llevan el RTD1283).

    Saludos.
Accede o Regístrate para comentar.