¡Hola Forastero!

Pareces nuevo por aquí. Si quieres participar, ¡pulsa uno de estos botones!

Firmware Modificado OPENHMR-MOD V0.4 para el HMR-1000/2000

edited noviembre 2012 en Modding
INFORMACIÓN

- Basado en el firmware 757.
- Incluye el jukebox MIG http://www.stevetech.it/
- Youtube funciona de nuevo. Versión recortada basada y usando código de http://playon.unixstorm.org/youtube.php
- AutoStandBy (el reproductor se apaga después del tiempo que le indiques).
- Se pueden ordenar los canales de la TDT tanto desde el IMS como desde la interface web.
- Guardas de las grabaciones desde la EPG (se añade un tiempo antes y después de las grabaciones).
- Se puede iniciar en la TDT.
- Se puede deshabilitar el acceso a la interface web.
- Se puede deshabilitar el servidor Telnet. Por defecto ya viene deshabilitado.
- Se incluye Dropbear, servidor SSH que viene habilitado por defecto en sustitución de Telnet (más seguro).
- Se pueden guardar/restaurar hasta 3 configuraciones distintas.
- Incluye una herramienta para solucionar problemas del disco.
- Interface web ampliada con nuevas funciones (mando a distancia, ordenación de canales, etc...)
- Se puede activar/desactivar la swap.
- Posibilidad de instalar/desinstalar paquetes de software adicionales (según disponibilidad).
- Incluye nuevos binarios (unrar, sqlite3, etc, etc...)
- Soporte de PHP
- Soporte básico de scripts Lua


LICENCIA Y AUSENCIA DE GARANTIA

Esta modificación de firmware se ofrece bajo la versión 3 de la licencia GPL. Si no has recibido una copia de dicha licencia, puedes verla en http://www.gnu.org/licenses/

Como la modificación del firmware se licencia libre de cargas, no se ofrece ninguna garantía sobre dicho software. Dicha modificación se ofrece «tal cual», sin garantía de ninguna clase, bien expresa o implícita, con inclusión, pero sin limitación a las garantías mercantiles implícitas o a la conveniencia para un propósito particular. Cualquier riesgo referente a la calidad y prestaciones de la modificación del firmware es asumido por usted. Si se probase que la modificación del firmware es defectuoso, usted asume el coste de cualquier servicio, reparación o corrección.
En ningún caso, ningún tenedor del copyright ni ninguna otra parte que modifique y/o redistribuya este firmware modificado según se permite en la Licencia GPL será responsable ante usted por daños, incluyendo cualquier daño general, especial, incidental o resultante producido por el uso o la imposibilidad de uso del firmware modificado (con inclusión, pero sin limitación a la pérdida de datos o a la generación incorrecta de datos o a pérdidas sufridas por usted o por terceras partes o a un fallo del firmware al funcionar en combinación con cualquier otro programa), incluso si dicho tenedor u otra parte ha sido advertido de la posibilidad de dichos daños.

[CONTINUA EN EL SIGUIENTE POST]
«13

Comentarios

  • edited noviembre 2012
    NOTAS A TENER MUY EN CUENTA

    - Es muy posible que tenga fallos. De todas formas, hemos puesto el máximo empeño en que si éstos apareciesen no supongan un gran problema. Aun asi, se comunica, que no poseeemos ninguno de estos modelos en concreto, por lo que los probadores sois vosotros mismos. Se agradecerá que seáis comprensivos y, si alguien encuentra algo que no funciona como debiera, lo comunique en este hilo.

    - Está pensada para reproductores con disco duro interno. Si no lo tienes, NO INSTALES ESTE FIRMWARE.

    - En el menú IMS del BitTorrent desaparecen los nombres de las descargas durante un lapso de tiempo cuando borras algún torrent. - Algunos vídeos de youtube no son reproducibles (han sido borrados, el autor los ha marcado como privados o no se permite su reproducción por cualquier otra causa).

    [CONTINUA EN EL SIGUIENTE POST]
  • edited noviembre 2012
    INSTALACIÓN

    El método de instalación es el mismo que usamos para instalar la versión 757 oficial de O2Media. Eso sí, salvo que tu firmware actual sea la versión 0.4 RC, se ha de usar el método seguro (apagado completo con el botón trasero y mantener presionado el botón HOME mientras se vuelve a encender y hasta que aparece el mensaje INSTALL).

    ENLACES DE DESCARGA<br><br><strike>OPENHMR-MOD V0.4 HMR2000 07-10-12 ==>>>Mod firm v0.4 para HMR2000 basada en 4Geek medley EVO v757. Valido para O2media HMR2000,4geek medley3 Evo y Ellion X3-TR21.<br>OPENHMR-MOD V0.4 HMR2000 Ver. 3 03-11-12
    ==>>> Mod firm
    v0.4 para HMR2000 basada en 4Geek medley EVO v757. version 3
    Valido para
    O2media HMR2000,4geek medley3 Evo y Ellion X3-TR21.<br>OPENHMR-MOD V0.4 HMR2000 Ver. 4 11-11-12 ==>>>Mod firm
    v0.4 para HMR2000 basada en 4Geek medley EVO v757. version 4
    Valido para
    O2media HMR2000,4geek medley3 Evo y Ellion X3-TR21.
    </strike><br>OPENHMR-MOD V0.4 HMR2000 Ver. 5 <font color="#ff0000"><b>FINAL</b></font> <font color="#009900">12-11-12</font> ==>>><br>Mod firm v0.4 para HMR2000 basada en 4Geek medley EVO v757. version 5<br>Valido para O2media HMR2000,4geek medley3 Evo y Ellion X3-TR21.
    <br>
    <strike>OPENHMR-MOD V0.4 HMR1000 07-10-12 ==>>> Mod firm v0.4 para HMR1000 basada en O2media HMR1000 v757 Valido para O2media HMR1000, Ellion X3-TR11 y Radiogears Itab58W<br>OPENHMR-MOD V0.4 HMR1000 Ver. 3 03-11-12
    ==>>> Mod firm
    v0.4 para HMR1000 basada en O2media HMR1000 v757 version 3
    Valido para
    O2media HMR1000, Ellion X3-TR11 y Radiogears Itab58W<br>OPENHMR-MOD V0.4 HMR1000 Ver. 4 11-11-12 ==>>> Mod firm
    v0.4 para HMR1000 basada en O2media HMR1000 v757 version 4
    Valido para
    O2media HMR1000, Ellion X3-TR11 y Radiogears Itab58W</strike><br><br>OPENHMR-MOD V0.4 HMR1000 Ver. 5 <b><font color="#ff0000">FINAL</font></b> <font color="#009900">12-11-12</font> ==>><br>Mod firm v0.4 para HMR1000 basada en O2media HMR1000 v757 version 5<br>Valido para O2media HMR1000, Ellion X3-TR11 y Radiogears Itab58W.<br><br>Notificaciones, comentarios, bug y problemas a partir de aqui, por favor.
  • Hola,

    Corrección de unos de los bugs notificados por chucky, cuando apagas por el mando si que puedes volver a encender desde el botón del frontal, desde el que no se puede es desde el botón del mando.

    Saludos,
  • Notificado por mi, no, son notificados por vosotros. Veis, ese es un punto importante. Creo que ya pregunte si desde el frontal encendia y deciais que no. Por favor acladme este punto.

    Al hilo de lo que dices en el otro post, colaboras fenomenalmente, que es probando, a ver cuantos ves por aqui como tu.

    Saluditos.
  • Cristrj, una pregunta:
    ¿Si lo apagas desde el frontal, se enciendes desde el mando?
  • Hola Chuky,

    No, desde el mando no se puede volver a encender de ninguna forma, pero te lo confirmo esta tarde.

    A lo que preguntabas ayer, a través del botón frontal puedes encender y apagar, a través del mando puedes solamente apagar. A través del autostandby apagas y a través del mando por web también apagas, pero no puedes encender obviamente...

    Conclusión si lo apagas desde el mando, frontal, auostandby o web sólo lo puedes encender o bien a través del botón frontal o bien desde el botón trasero.

    Espero te haya podido dejar claro el funcionamiento.

    Un saludo,
  • Una prueba mas. entrad en herramientas del IMS y desactivar la SWAP, (desactivada / sin uso)

    Volver a hacer la prueba del apagado y encendido desde el mando.
  • Hola chicos

    Actualicé mi HMR 2000 y veo los menús nuevos, como el OPEN-HMR, pero todas las opciones en las que aparece desactivado, intento ponerlas en activado y no me deja.

    El menú nuevo del parte metererológico se ve bien y veo mi ciudad con el tiempo. (Por lo que internet veo que funciona).

    Y otra cosa, youtube, sigue apareciendo el dibujito "DVD-R" al intentar ver algún video y algo escrito sobre ese dibujo que no se lee, y no me deja ver ningún vídeo.

    Algo estoy haciendo mal?

    saludos

    Darsu
  • me respondo a mí mismo. Ya sé lo que hice mal y lo posteo por si a alguien le puede ayudar.

    Si actualizáis el firmware desde la opcion actualizar del menú, esta versión nueva no os funcionará bien. Tenéis que actualizar apagando el aparato con el interruptor trasero. Introducir el USB con la versión y después, manteniendo la tecla de la casita pulsada, encender el aparato y esperar a que se reinicie solo.

    Ya me funcionan todas las opciones.

    Gracias por esta versión la estaba esperando desde hace tiempo.
  • Buenos días,

    He hecho la prueba que comentaste de desconectar la swap y el resultado es el mismo, sigue sin funcionar el on del mando.

    Saludos
  • Gracias cristrj.

    imagino que tras desactivar la swap, has reiniciado y comprobado que esta desactivada y sin uso.
  • Sip, acabado de probar desconectando swap y reiniciando desde botón trasero, y comprobando que laswap está dseactivada y....mismo resultado negativo

    Saludos,
  • Gracias.

    Estamos mirando a ver si tiene solucion. Pero no prometemos nada.
  • Hola chuky, yo tengo el HMR 2000 y funciona todo correctamente salvo ese tema de volver a encender desde el mando a distancia. Hice todas las pruebas que mencionas, y me pasa lo mismo que a cristrj
  • Hola Darsu,

    Una pregunta, ¿puedes acceder bien desde pc por samba a los archivos del disco duro del HMR2000? porque a mi me va fatal, se me cuelga cuando intento acceder, podrías probarlo para descargar que sea un fallo de firmware,

    Saludos,
  • Exacto darsu, confirma si tienes o no, ese problema.
  • Hola

    Yo tengo conectado el aparato en red y desde cualquier ordenador de mi casa (tengo dos portatiles y un fijo , todos en la misma red) si que veo el disco duro en la carpeta RED del windows, con las carpetas de las películas. Tengo activado Samba y FTP. Y puedo copiar y mover las peliculas de un sitio a otro sin problemas. Si queréis que haga alguna prueba más me decís.

    saludos
  • Me acaban de cancelar la cuenta de mediafire. tendre que subirlos a otro sitio.
  • Subidas nuevas versiones con "POSIBLE" solución al problema del encendido desde el mando.
    El funcionamiento de SAMBA, es el mismo que en un firm de origen.

    Supongo que tardara algo mas en arancar.

    Por favor, comentarios afirmativos Y negativos, todo nos sirve, y cuantos mas mejor.
  • Hola!!
    Muchisimas gracias por la actualizacion!!!
    Por si os sirve yo tambien tengo el mismo problema a la hora de encender... desde el mando no funciona....
    Lo demas en principio perfecto... (incluso ordena los canales...)
  • Hola a tod@s, CHUCKY primero que todos muchas gracias por lo que haces por nosotros.

    Ahora vamos a los poblemillas, a mi me pasa lo mismo con el mando igual que a los demas. Tengo otro problema, cuando estoy viendo videos de youtube a la media hora aproximadamente, se queda bloqueado con el dichoso logotipo del dvd, no se si eso tiene solucion, pero eso es cosa de pofesionales como tu.

    Ahora voy a ver si sabeis algo o si os a pasado a vosotros, busco los canales tdt en el televisor y por ejemplo me salen 57 canales, bueno los busco en el hmr2000 y solo me salen 51canles; me he fijado que cuando lo intentas buscar manualmente faltan canles, sabeis algo de eso.

    un saludo.
  • Pues hala, a probar la version 2, pero dejaros a mano la version anterior. no sea que falle.
  • Alto, quietos, STOP

    =;

    Se me ha olvidado cambiar un archivo en la version 2, asi que ni la probeis, paso a hacer una version3.

    Lo siento, cosas de la memoria de los abuelos. 

  • Buenos dias chucky, pero duermes algun dia? siempre estas pensando, eres un crack.

    A AAA y eso de memoria de abuelos mentira ya les gustaria a algunos jovenes tener la memoria que tienes tu.

    Un saludo y esperando esa version 3, jejejeje  
  • Version 3 subida.

    Tardando estais.
  • De:skondi2 noviembre 2
    Hola a tod@s, CHUCKY primero que todos muchas gracias por lo que haces por nosotros.

    Ahora
    vamos a los poblemillas, a mi me pasa lo mismo con el mando igual que a
    los demas. Tengo otro problema, cuando estoy viendo videos de youtube a
    la media hora aproximadamente, se queda bloqueado con el dichoso
    logotipo del dvd, no se si eso tiene solucion, pero eso es cosa de
    pofesionales como tu.

    ¿Ves vídeos de youtube que
    duran mas de media hora, o viendo varios vídeos distintos, cuando llegas
    a la media hora? ¿Te sale el salvapantalla, o el simbolo de que no
    encuentra el rss?


    Ahora voy a ver si sabeis algo o si os
    a pasado a vosotros, busco los canales tdt en el televisor y por
    ejemplo me salen 57 canales, bueno los busco en el hmr2000 y solo me
    salen 51canles; me he fijado que cuando lo intentas buscar manualmente
    faltan canles, sabeis algo de eso.

    Contestado muchas
    veces, problemas de señal de la antena, revisa cables, conexiones,
    conectores, separa cables y si es necesario, pon un amplificador de
    señal.

  • ¿Ves vídeos de youtube que
    duran mas de media hora, o viendo varios vídeos distintos, cuando llegas
    a la media hora? ¿Te sale el salvapantalla, o el simbolo de que no
    encuentra el rss?

    Son videos cortos alguno de 10 otros 16 o por ahi, y sale el logo del dvd cuadrado diciendo confirm pero aprietas y nada, tengo que apagar y ecender.
  • Contestado muchas
    veces, problemas de señal de la antena, revisa cables, conexiones,
    conectores, separa cables y si es necesario, pon un amplificador de
    señal.

    Todo esto esta probado ya que soy instalador.

  • chucky, provada la version 3 a medias, lo del encendido del mando sigue igual. no he provado nada mas ya que me tengo que ir ya provare esta tarde y te digo algo.


    Un saludo.

    P.D.: Si pasas por Javea (Alicante) Me dices algo y te invito, es muy grande lo que haces.
  • ¿Ves vídeos de youtube que
    duran mas de media hora, o viendo varios vídeos distintos, cuando llegas
    a la media hora? ¿Te sale el salvapantalla, o el simbolo de que no
    encuentra el rss?

    Son
    videos cortos alguno de 10 otros 16 o por ahi, y sale el logo del dvd
    cuadrado diciendo confirm pero aprietas y nada, tengo que apagar y
    ecender.

    Nunca he visto media hora de videos, habra que mirarlo
  • Contestado muchas
    veces, problemas de señal de la antena, revisa cables, conexiones,
    conectores, separa cables y si es necesario, pon un amplificador de
    señal.

    Todo esto esta probado ya que soy instalador.

    El sintonizador de los HMR, (Y de todos los mediacenters realtek) es muy sensible, sin embargo, yo no tengo ese problema, es mas tengo mas canales en los cubos (107) que en algunas TV, y eso que mi instalacion de antena no es mu normal, 3 cubos, 4 TV, y 2 PC conectados a la antena, y ya te digo que "mas o menos" todo OK (En la TV mas lejana, hay veces, que baja la señal)
  • Todo ok con los canales, un P-T- vecino se habia conectado al cable de la bajada. Y lo Mismo 5 TV 2 Cubos.

    Gracias
  • Buenas tardes CHUCKY, otra cosita mas del cubo, he hecho la prueba con youtube y esta vez solo me ha dejado 14 minutos que es lo que duraba con un video musical de exitos del 2011, despues del video solamente te deja ir cambiando de ventana en ventana sin poder reproducirlos.
    .- Ahora cuando lo apago hace el ruido como si de un intermitente se tratara (tic tac tic tac) a veces se apara y otras no tengo que apagarlo del interruptor trasero.

    No se si te ayudo con estas cosas, pero yo te voy informando. Ha lo de ordenar canales ok.Voy a serguir probando cosas.


    Un Saludo

  • Hola Chucky!!
    Probada la v.3 y el mando sigue sin encender..... el resto de cosas parece funcionar bien.
    Muchas gracias por la currada y a ver si hay suerte....
  • Hola Chuky, al fin puedo entrar en esta página, estos días atrás no me dejaba.

    Yo no he actualizado la versión 3 porque no se donde metí la que tengo instalada... pero si dicen que no enciende, mejor no la pruebo ya que la que tengo me va bien.

    En cuanto los videos de YouTube, me pasa lo que dice skondi, que pasado un rato, navegando por varios videos, como que se satura y sale el logo maldito, pero reiniciando, vuelve a ir bien.

    saludos
  • Mi cuenta de mediafire vuelve a estar disponible, con lo que sepueden descargar todas las versiones del firm0.4.

    El que otros, digaun que no va, no es excusa, necesitamos informacion, y por ahora solo lo han reportado 2 usuarios, que ademas no dicen con que aparato, que podria ser el mismo, o no.

    En fin que teneis que ayudar mas :-(

  • Hola Chucky!
    Mi modelo es el hmr 2000..., si te hace falta cualquier otra cosa me dices...
    Y muchisimas gracias por la currada que os pegais.
  • no tengo el enlace del la version 1 del 7-10-2012, y el enlace de arriba no va, la puedes volver a poner? en cuanto la tenga instalo la 3.

    gracias

    saludos

  • ¿De que chisme?
  • Buenos días;

    Estoy out un finde y me encuentro con que hay nuevo Firm y nuevo IMS!!!!!

    Pregunta, ¿el versión 3 es de este fin de semana?.

    Y el nuevo IMS es también de este finde? en ese caso, para tirar de las opciones del IMS del sistema, tenemos que cambiarlo cada vez o vienen incorporadas en este?

    Y último que hacemos con el anterior, lo borramos?

    A ver si tengo tiempo e instalo ambas cosas, un saludo fieras!


  • edited noviembre 2012

    Si, la version 3 es de este fin de semana.

    La opciones del de sistema, van incluidas en el nuevo IMS.

    Lo de borrarlo al gusto, por ahora se renombran las carpetas al instalar el nuevo.

  • El enlace de la versión para el HMR-2000 del hilo de enlaces y descargas da error.

    Saludos.
  • Si, si te intentas descargar la version1 da error porque me la borraron los de mediafire y aun no la he subido.

    Esperaba que alguien mas hiciera comentarios sobre como va la version3, que por lo que parece funciona igual que la 1 y la 2. de hecho Hammarby esta esperando que le conteste si funciona el sistema, pero como su opinion la aportan pocas personas (solo 2) pues estaba esperando a que pasara este fin de semana, y luego ya arreglar los enlaces.

    Aun asi los codigos de irfake, tan solo los envio cristrj y hasta podria ser de eso. :-(
  • Si el reproductor se apaga cuando se pulsa la tecla de encendido/apagado en el mando a distancia es porque el código es correcto. En cualquier caso, eliminar a Irfake de la ecuación es bien sencillo, se añade una # al principio de las siguientes 2 líneas de /usr/local/etc/rcS

    /sbin/insmod /usr/local/etc/venus_ir_new.ko
    /usr/local/etc/irfake4&

    y se reinicia.  Dejarán de funcionar varias cosas, pero lo único que interesa es comprobar si se enciende/apaga normalmente desde el mando a distancia. Si fuera así, supongo que se debería eliminar irfake antes de suspender (en el script suspend), pero eso ya sería el siguiente paso a probar.

    Saludos.


  • edited noviembre 2012
    Pues a ver si alguien se anima a hacer la prueba, que al final parece que tenemos nosotros mas interes que los propietarios de estos chismes. (Porque descargas del IMS para estos chicmes, ya hay mas de 20)

    las lineas deben quedar como sigue:

    # /sbin/insmod /usr/local/etc/venus_ir_new.ko
    # /usr/local/etc/irfake4 -R&

    Dependiendo de las repuestas que tenga esto, hare o no un nuevo firm. :-(

  • Buenas tardes,

     Chucky y compañía, siento no haber podido responder antes...llevo una semana de curro...y de curro luego en casa...con lo cual no me ha dado tiempo a prácticamente ni respirar...

    Al trema, el On/off sigue igual, pero veo que has comentado lo de los códigos...así que a ver si dispongo de un poco de tiempo para comprobar el código del botón...a ver si ahora voy a ser yo el responsable.. 
    :(
  • edited noviembre 2012
    Gracias, al final lo estas haciendo tu todo.

    Ademas de los codigos haz la prueba a editar /usr/local/etc/rcS, lo puedes hacer por FTP, no olvides darle luego los permisos de ejecucion.

    Y si al final es por los codigos, lo sentiria por ti, porque los demas se molestan poco ( A ver si al final se pica alguien ;-) )
  • Haré pruebas el domingo por la tarde.

    He estado con curre y en el extranjero y no he trasteado casi nada. Pero me comprometo a colaborar.

    Gracias por preocuparos de nuestros bichos.

  • edited noviembre 2012
    Hola!
    Si os quiero entender bien hay que entrar por FTP, y en la ruta /usr/local/etc/rcs modificar las lineas y poner las que dice chucky, no??
    Bien pues yo en mi hmr2000 esta ultima carpeta no la tengo (rcs)...
    Otra cosa, una vez encontrada, como "edito" las lineas...?
    Releyendo el hilo parece que para encenderlo teneis que hacerlo desde el interruptor trasero, no? Bien pues yo si que puede hacerlo desde el boton de encendido del cubo (tarda un rato), lo que no puedo es desde el mando. Y otra cosa igual que ha skondi2 a mi tambien me hace un rudio (tak,tak,tak...) al apagarlo, dura unos 5 segundos y para.
    Muchas gracias!!

    Edito; Encontrado el rcs no es un carpeta es ya el archivo dentro de esa ruta, ahora me falta saber como añadir los comandos..
    Edito: Para editarlo boto derecho encima del archivo y opcion de editar...

    Realizado los cambios sigue sin encender del mando.... es necesario darle al boton de encendio del cubo...
    A seguir probando....(las modificaciones de las lineas las borramos...???) gracias!!
  • Hola!

    Llevo tiempo siguiendo el foro, pero hasta ahora no había participado. Tengo un HMR-2000 con el firm 757 y me he decidido a cambiarlo por el OPENHMR-MOD V0.4.

    Y de momento confirmo los 2 bugs que estan comentando:

      • No se enciende desde el mando.
      • Y al apagarlo desde el mando hace un tik-tak durante 6 o 7 segundos.

    Un saludo a todos y gracias a chuky, calimocho, etc. por el gran trabajo que están haciendo.
Accede o Regístrate para comentar.