¡Hola Forastero!

Pareces nuevo por aquí. Si quieres participar, ¡pulsa uno de estos botones!

Firm 739 MOD

edited enero 2011 en Modding
En esta pagina:

mhdworld
Tienen el firm 739, modificado. como vereis hay version para el Ellion HMR600 y para el 4Geek medley3, con lo que hay para los tactiles y para los no tactiles.

Estas son las mejoras que incluye:
Lunes 24 de Enero de 2011 00:20
Edición de canales de televisión analógica (ATV) y digital (DTV).
Posiblidade de añadir emisoras de radio de internet.
Navegador por los discos duros (HDD-Explorer).
NDAS Server en algunas versiones de cubos.
Conexión con itunes via firefly (itunes Mediathek)
soporte de software empaquetado con ipkg.
Servidor http ligero (lighttpd).
Soporte PHP.
Conexiones cifradas via ssh con SCP
twonky media server
Wake on Lan
Planificación de tareas (cron job).
Reproducción de soportes CD-DVD-BD
Difusión de las grabaciones via http (Timeshift streaming). Mira IPTV en las FAQ
Transferencia de ficheros ftp
Servidor Samba.
individual NAS settings
Cliente Bittorrent
Agenda para grabaciones temporizadas (para cubos con la base de datos SQlite3).
Sincronización de hora via NTP.
Control remoto en la interfaz web.
Gestor de descargas via HTTP.
Instalable via disco duro o USB.
Control de puerto y acceso HTTP con contraseña.
Control de puerto y acceso FTP con password.
Copia de seguridad y resturación de la configuración personal. (Lista de canales)
Todo en una interfaz web configurable.
y todo esto en una interfaz web y preparada para instalar en una sencilla imagen ext2-Image

¿Alguien lo ha probado?

y lo mejor, ¿Alguien se atreve a probarlo?:face-devil-grin:
«1

Comentarios

  • edited enero 2011
    Si ese firm funcionara junto con la amplilación del IMS podría ser la bomba.:face-smile::face-smile:
    ¿qué riesgos se correrían? ¿se podría joder el aparato? (me extraña, la verdad....en todo caso que no funcionara podría ser lógico, pero romperse....no creo ¿no?)
    !! Animo muchachos !! ¿Quien se la juega?

    PD. Chucky, habría que instituir una mención especial para kamikaces del firm de laboratorio..jeje:face-devil-grin::face-devil-grin:
  • Por lo que he leido, a los que lo han instalado, lo mas que les ha pasado, es que el aparato tras un rato funcionando se reinicia. pero porque habian instalado el de no tactiles en tactiles.

    la version para tactiles, basada en el 739 de 4geek, ha sido lanzada el dia 28 de enero, asi que como veis es muy reciente y no hay comentarios respecto a ella, ni buenos, ni malos.:face-plain:

    Si, desde luego que los kamikazes tienen su merito,:face-devil-grin:(muchas gracias chicos) pero visto sus ventajas, yo casi que estoy decidido a probarlo. Me encanta el servidor UPNP twonky, el mando a distancia desde el PC, el DeCCS de los DVD(En la lista no lo pone, pero en la descripcion mas detallada pone que puedes poner en el ODD discos originales), ademas de añadirle PHP, con lo que los scrips del Xtreamer, tipo Xjukebox, ya podrian funcionar.

    La verdad que tiene todo lo que firsco queria colocar en el mod firm, y si encima esta hecho sobre la base del 739, pues miel sobre hojuelas:face-devil-grin:
  • Realmente no debería haber problemas en los tactiles que no haya en los no tactiles, solamente cambia el dvdplayer. Yo cogi el sdk del 738, copie el dvdplayer del 739 tactil y ahí lo tengo funcionando. Así que cualquier comentario que hagan en los no tactiles se debería aplicar al nuestro.

    De todo lo que lleva no conozco casi nada.
    ¿El media server es para reproducir archivos en el PC? Porque yo estoy mas interesado en lo contrario que ya lo tiene.
    ¿Que es lo de configuraciones del NAS? Porque NAS ya lo tiene con lo del samba.
    El NTP esta bien, mantiene la hora sincronizada, y si entiende el horario de verano ya no habrá problema con las horas.
    El ssh tampoco me hacia falta, no pensaba acceder desde fuera de casa.
    Lo del itunes ni idea, no lo uso, tengo linux.
    El cron y el wake on lan tampoco creo que le de uso.
    ¿Como es el gestor de descargas http? A eso si que le puedo ver mas utilidad, es uno de los usos para los que queria el aparato, hacer ahí las descargas grandes.
    ¿El bittorrent es el mismo? ¿Dice alquien que tal va?
    ¿A que se refieren con la edicion de canales? ¿Y el navegador del HDD? ¿Es algo diferente a lo que tenemos?

    Yo realmente lo unico que necesitaría es el DeCCS, quizas el gestor de descargas, lo del ipkg para instalar el amule, que alguna vez aun descargo cosas muy viejas y solo lo encuentro ahí. Claro que yo no veo demasiado la tele, ni peliculas o series. No se si me animare a probarlo, si al menos hubiera pantallazos o algo más detallado, al menos no lo encuentro.
  • Lo contrario del media server ya se puede hacer con acceder a la funcion PNP. El media server esta bien para la gente que tiene TV con conexion a la red, o si por ejemplo quieres ver las pelis de HMR en otra habitacion, bien a traves de una xbox, wii, o ps3, o cualquier otro aparato que use UPNP, a mi por ejemplo, mi hijo podra ver en su habitacion las pelis que tiene en el HMR con encender la wii y con el navegador explorar la IP del HMR.

    El samba y el NAS aunque para mi tambien me parece lo mismo, no debe serlo, de hecho este NAS esta cifrado.

    El torrent ni ideas de cual es.

    En cualquier caso no deja de ser algo interesante, tiene muchas funciones, no hay porque usar todas y para colmo nos lo dan ya hecho.:face-devil-grin:
  • edited enero 2011
    Y no se les ha ocurrido añadir una opción de "default startup" para poder ver la tele con solamente encender el HMR? Yo creo que algunas noches ya incluso sueño con la secuencia ON-ENTER-DTV...
    [cite] enpijama:[/cite]
    ¿El media server es para reproducir archivos en el PC? Porque yo estoy mas interesado en lo contrario que ya lo tiene.

    Yo reproduzco los archivos del HMR desde el PC. Para ello, desde el PC, hay que conectar antes una unidad de red cuya IP es la del HMR. Entonces con el explorador de Windows accedo a los archivos y con el VLC los reproduzco sin problemas.
  • De todas formas cuando he abierto el enlace que has puesto no he visto que diferencie entre tactiles y no tactiles. ¿lo hace y a mi se me ha pasado?. Y otra cosa sobre el concepto "mod" que no termino de tener clara al 100% : ¿quiere esto decir que mantiene el firm 739 y sobre él añade las funcionalidades citadas o sustituye todo el firm ? (esto último me extrañaría puesto que el peso del mod es casi la quinta parte del firm 739 en cuanto a tamaño)
  • no se trata de hacerlo HACIA el PC, sino HACIA dispositivos mas simples, y que no se pueden configurar.
    El PC como fuente o como destino con el samba nos sobra.
  • edited enero 2011
    Me corrijo a mi mismo: una vez descomprimido ocupa 138 Megas (igual que el 739), osea, que instala totalmente el firm ya "tuneado". :face-smile:

    PD. Creo que me voy a dejar arrastrar por la tentación......tanta mejora a la espera de ser testeada me está poniendo los dientes muyyyyyy largos. !!!! ALLÁ VOY....... !!!! (espero que haya agua en la piscina y no me pegue un galletón...)
    (Volveré.....):face-devil-grin:
  • He estado mirando en la página, pero no sé exactamente qué hay que instalar. He entrado en la sección de 4Geeks (mi aparato es táctil), y me he descargado el fichero con el firmware, pero menciona algo de que también hay que instalar la vesión adecuada del IPKG, que no tengo ni idea de qué es, para qué sirve, cual es la adecuada, ni cómo se instala. :face-crying:
  • No distingue entre tactiles y no tactiles. Hya una version para el ellion HMR600, que seria la que valdria par los no tactiles, y otra distinta para el 4Geek medley3 que es la que tendriamos que poner a los tactiles.

    Segun me ha parecido entender, las instrucciones son:

    Poner en en la raiz de un llavero USB, el archivo install.img del firm 739 mod seleccionado.

    Poner en la misma raiz del USB el contenido del archivo MHDWorld-4.10e_30.01.2011.zip que nos habremos descargado de la misma pagina en la seccion de allgemein --> IPKG

    Acualizar el firm de la forma habitual, esperar que el aparto reinicie NO QUITAR EL LLAVERO USB( he leido en algun sitio que es necesario tenerlo puesto en el primer reinicio)y luego seguir las instrucciones en pantalla para instalar el IPKG, que es lo que contiene las utilidades.

    El mod firm , lo unico que hace es abrir una puerta trasera para poder colocar la aplicacion.


    Ojo, esto es lo que yo he entendido. Aun no lo he probado.
  • edited enero 2011
    Aqui estoy de nuevo.
    He puesto en el llavero USB el archivo install.img con el firm 739. También la versión del IPKG que según comenta son los archivos que incluyen las mejoras mencionadas, y también otro archivo que aparece junto al install.img al descomprimir el firm correspondiente.
    He actualizado desde el menú de actualizar el sistema (en configuración).
    Me aparece la misma interfaz a la que estamos habituados pero....!! CIELOS !!.... no me responde el mando a distancia.
    He probado tanto con el firm de Ellion como con el de 4Geeks y nada, el mismo problema en ambos.
    Igualmente he intentado acceder desde el PC a la página web que comenta pero no consigo entrar.
    Desde el PC me reconoce el HMR via wifi (mantiene la configuración wifi), pero no sé si no puedo entrar en la pagina que comenta porque el puerto no sea el 65000 como comenta en la página.
    Por lo demás puedo navegar por la interfaz via frontal del HMR, lo cual es bastante coñazo.
    Estoy releyendo las instrucciones para ver dondo puede estar el error, pero de momento estoy en standby.
    Agradeceré vuestras aclaraciones si sabeis algo.:face-plain::face-plain:
  • comentan que no hace falta poner el puerto, com poner la direccion IP, ya deberias ver la nueva interfaz
  • ¡¡¡ Que Güevos tienes !!! Tatanka
  • Chucky, pongo sólo la IP y no se me abre la interfaz.......sin embargo sigue reconociendo el entorno de red wifi.....(debe de ser una chorrada pero hasta que no dé/demos con ella....):face-crying:
  • [cite] chucky:[/cite]comentan que no hace falta poner el puerto, com poner la direccion IP, ya deberias ver la nueva interfaz

    Además, si entrara sólo por la IP......no lo tengo claro, pero si tuviera el BT en on se me abriría la página del BT ¿ok?. Lo cual tampoco ocurre (lo acabo de comprobar poniendo el BT en on). Y estando en off el BT lo dicho: tampoco. :face-sad:
  • ¿has probado la instalación con el sistema clasico del interruptor trasero?
  • El firmware, EN TEORIA, lo que hace es cambiar la web del HMR600. Normalmente, cuando tú accedes a dicha web, como dice tatanka, se te abre el interfaz del BT. Honki lo que ha hecho es eliminar dicho interfaz y poner su propio index.html con el código necesario para instalar el paquete con todas las mejoras en el disco duro interno (creo que en la partición de 500 MB que algunos han dicho que no se está usando). ¿Cuál es el fallo? No estoy seguro porque apenas lo he mirado, pero me parece que está en la configuración del servidor web o del superservidor.

    tatanka, prueba a entrar por Telnet siguiendo las instrucciones del hilo correspondiente en este foro y dinos si te es posible. Si no puedes entrar, lo que está fallando es lo que en unix se suele llamar Superservidor (Inetd) que es el encargado de ejecutar ciertos servidores (en el caso del HMR el telnetd y el servidor web). Prueba también a acceder al HMR por ftp.

    Si no puedes acceder ni por telnet ni por ftp y, por supuesto, tampoco por http, la única solución que te queda es reinstalar un firmware correcto (el que has instalado tiene un bug serio).

    Si puedes acceder por alguno de los métodos expuestos, habría que seguir investigando.

    Saludos.
  • De momento estoy reinstalando por el método antiguo por si las moscas. Si veo que sigue igual vemos el tema del telnet.
    Os mantengo informados :face-plain:
  • edited enero 2011
    !!!!!! FUNCIONAAAAAAA !!!!!! :face-devil-grin::face-smile::face-devil-grin::face-smile:

    No he respondido antes porque he tenido varias confusiones y me ha llevado un tiempo aclararme haciendo pruebas.
    En primer lugar Chucky: tenías razón. He reinstalado el firm por el método clásico (un auténtico coñazo porque no había manera de conseguir que leyera el pendrive). Una vez reinstalado de esta forma se soluciona el problema que tenía con el mando a distancia.
    A primera vista la interfaz es la misma. He cogido el firm de 4Geeks. Por lo que veo al IMS le han añadido nuevas funcionalidades :face-smile::face-smile:: Metafeeds, Xtreamer: The ultimate list, y CSB-Deutsche Feeds. Sólo he tenido tiempo de entrar en el de Xtreamer y ver el canal de Lo mejor de YouTube, que por cierto se veía super fluido y sin saltos.
    A partir de aquí he tecleado en el PC la dirección IP del hmr a pelo y me ha salido la pantalla roja del mhdw diciéndome que el navegador no se ha instalado en el dispositivo de arranque del aparato (cosa que no termino de entender en ese momento). Entonces me da a elegir si quiero instalarlo en el pendrive -sda- o en el disco duro -hdd1-. Elijo este último y a continuación me dice que va a proceder a instalarlo. Me indica que una vez instalado el HMR se reiniciará automáticamente y que para entrar en la página hay que teclear la dirección IP del HMR puerto 80. De todas formas también dice que para entrar por la puerta trasera del HMR y poder volver a elegir donde queremos instalar el navegador (caso de habernos dado error) la dirección a teclear es la misma IP pero el puerto es el 65000.
    Importante: avisa que una vez elegido el destino e iniciada la instalación se cierre el navegador (el del PC) y que se borre la caché de navegación. En prinpicio no lo hice y creo que esto me dió pié a que no funcionara a la primera sin saber claramente el porqué.
    Finalmente el HMR se reinicia. No os mosqueeis ya que durante la instalación (del MHDW) se queda un buen rato en la pantalla de bienvenida, pero finalmente desaparece y arranca definitivamente.
    A partir de aquí entro via PC en la IP del HMR puerto 80 y ....... ! se abre la página de configuración ! (por fin....porque me ha costado varios intentos reinstalando). Desde aquí teneis todas las opciones disponibles que no son pocas.
    En mi caso estoy probando el BT, que por cierto, es el mismo de siempre pero que según veo tras cosa de 20 minutos no se cuelga :face-smile::face-smile: y mantiene una velocidad de descarga sobre los dos enlaces que he puesto bastante decente (103 y 170 en este momento).
    Estoy trasteandolo, pero de entrada tiene una muy buena pinta en cuanto a la gran cantidad de mejoras añadidas que incluye :face-smile::face-smile:
    Eso sí, al reinstalar el firm hay que volver a introducir la ampliación del IMS de Chucky, lo cual a estas alturas es pan comido.

    Animaros y a por él !!!!!
  • :face-devil-grin::face-devil-grin::face-devil-grin::face-devil-grin::face-devil-grin::face-devil-grin::face-devil-grin::face-devil-grin::face-devil-grin:
  • edited enero 2011
    Era demasiado bonito para ser cierto :face-crying::Creo que el BT se sigue colgando (si el firm base es el 739 y no han tocado nada en él creo que hereda sus errores.)
    Lo confirmo tras un rato de descarga.
  • El BT sí que lo han cambiado. Lo que no sé es si es el mismo empaquetado como paquete aparte o realmente ha habido modificaciones. En la flash prácticamente lo único que han cambiado es el tema de la web, aunque también se han añadido algunos ejecutables. Sin embargo, los añadidos han ido al disco duro.

    Saludos.
  • eeeeeeeeeeeeeeeeeeeeeehhh pero que pasa, aqui el probador soy yo, desde luego os dejo un momento y me quitais el puesto.

    Voy ha descargar y veremos que trae.

    Un saludo
  • edited enero 2011
    Pues por lo que veo y compruebo, sí que se bloquea como antes, y lo que es peor, el HMR se queda colgado (chungo) :face-sad: , lo cual todavía es peor.
    Desde luego la interfaz del BT es la misma, aunque el cliente por lo que leo en la página lo ha añadido el desarrollador en el paquete de instalación. Es evidente ya que en nuestro HMR el cliente BT aparece como off.
    No lo tengo claro al 100% pero tiene toda la pinta de ser como comento.
    De cualquier forma una vez que saquen el nuevo firm no tendríamos más que sustituirlo en la misma instalación y ver que pasa.
  • edited enero 2011
    Hay algunas mejoras que no entiendo para que sirven la verdad pero esta tarde noche lo instalo y pruebo, que no hay problema de ser conejillo de indias tambien que para eso estamos los tester jejejeje. La pregunta es si se instala como comenta chucky con el firm mas el ipkg junto a el en formato zip o el archivo ipk directamente, y esperar al reincio. Por cierto hay alguna forma de incorporarle navegador web a la modificacion o eso aun tenemos que esperar mucho.

    Saludos.
  • Pues de momento la version del ellion me deja sin mando a distancia, tan solo puedo apagar y encender, aunque con los botones puedo hacer algo......

    Os sigo contando.:face-devil-grin::face-devil-grin:
  • edited enero 2011
    [cite] joeblack:[/cite]La pregunta es si se instala como comenta chucky con el firm mas el ipkg junto a el en formato zip o el archivo ipk directamente, y esperar al reincio. Por cierto hay alguna forma de incorporarle navegador web a la modificacion o eso aun tenemos que esperar mucho.

    Tienes que descomprimir tanto el firmware como el ipkg. Es decir tienes que dejar los ficheros install.img y mhdworld_mipsel.ipk.

    Del navegador web pregunta a Ellion/O2Media, aunque igual ni siquiera ellos lo saben.

    Por cierto ¿Se leen bien los DVDs encriptados o se necesita descargar por otro lado software adicional?

    Saludos.
  • edited enero 2011
    Bueno hay que hacer la instalacion apagando y pulsando la casa, no por el menu (si lo haces por el menu te quedas sin mando).
    En el usb hay que poner el fichero install.img y el fichero mhdworld_mipsel.ipk

    Por ahora vamos bien, se ha instalado el firm.
    Despues vamos con el mozilla o el explorer y ponemos http:\\ip_del_HMR
    y en la pagina que sale le damos ha instalar y esperamos ha que se reinicie.

    ....

    ....

    En un rato mas que estoy esperando a que se reinicie.:face-devil-grin::face-devil-grin:


    Pos nada me he dado cuenta que si vuelves a la pagina del hmr me dice que el disco duro debe estar formateado para poder utilizar esto.....

    Asi que alla vamos (mi mujer me mata cuando vea que he borrado el ultimo capitulo de los protegidos)

    :face-devil-grin::face-devil-grin:
  • Pues despues de la consiguiente bronca.... he formateado y nada no me deja instalar la parte interesante de este firm.

    Estoy volviendo a reinstalar a ver que tal....

    Ya os dire algo
  • edited enero 2011
    Vamos a ver: poned en el pendrive tanto el archivo install.img como el que se genera junto con este al descomprimir el zip (tiene el nombre bastante largo). Y junto con estos dos los otros dos que se obtienen al descomprimir el ipkg (cuatro en total si no me equivoco). Todo lo que pongais en el pendrive debe estar descomprimido. Acordaos durante la instalación (mientras aparece la pantalla de bienvenida y vuelve a reiniciar)de borrar la caché del navegador y cerrarlo. Lo volveis a abrir una vez reiniciado el HMR.

    Acabo de llegar y al irme hace un par de horas he dejado descargando dos películas. La descarga ha finalizado sin problemas :face-smile::face-smile:, lo cual me hace intuir que el BT que incluye el mod es estable. Atando cabos estoy llegando a la conclusión de que es posible que el hmr se quede colgado cuando simultaneas el uso del IMS con una descarga via BT, porque si no recuerdo mal es lo que me ha pasado al hacer las pruebas anteriormente. Ha sido cuando he empezado a ver uno de los canales de YouTube (al tiempo que el BT funcionaba en segundo plano) cuando terminaba bloqueandose todo.
    Puede ser que el cuello de botella sature el procesador: ¿alguien apoya mi sospecha?
    Por un momento pensé que incluia navegador web pero no,:face-crying: creo que se me ha disparado la imaginación. Lastima porque habría sido la guinda del pastel.
    Por lo demás voy a seguir probando, pero todo parece funcionar bien.:face-devil-grin::face-devil-grin:
  • Yo me inclinaría más porque entrar al IMS necesite mas memoria y la llene, al no tener swap libre (mas bien no tiene nada) linux decide matar un proceso para liberar memoria y se carga uno que bloquea el aparato, porque no funcione sin ese proceso. Una opcion sería activar la swap, porque a partir del 7xx una de las particiones que se creaba era de swap pero no se activaba, no sé porqué. Supongo que este firm sigue sin activarla.
  • edited enero 2011
    [cite] enpijama:[/cite]Yo me inclinaría más porque entrar al IMS necesite mas memoria y la llene, al no tener swap libre (mas bien no tiene nada) linux decide matar un proceso para liberar memoria y se carga uno que bloquea el aparato, porque no funcione sin ese proceso. Una opcion sería activar la swap, porque a partir del 7xx una de las particiones que se creaba era de swap pero no se activaba, no sé porqué. Supongo que este firm sigue sin activarla.
    ¿Y como activamos la SWAP?.
    Por lo menos ya sabemos que si ambos procesos no funcionan simultáneamente con parar uno de ellos podemos usar el otro. El inconveniente es que si quieres detener el BT y tienes el PC apagado tienes que volver a encenderlo para detenerlo :face-sad:. Pero bueno....lo reservaremos para que descargue durante la noche o en momentos en los que no usemos el IMS (a falta de pan.....es mejor que tener el BT totalmente jodido como hasta ahora)(en este momento descargo a razón de 400 kB/s...no está mal...)

    PD. Por cierto: he mandado un correo (on English, of course....) a este máquina poniendole al corriente de nuestro trabajo e invitándole visitar nuestro foro y a colaborar con nosotros. Quien sabe.... si estuviera por la labor y no tuviera problemas con el idioma nos podría ser de gran ayuda.Fijaos en el trabajo que nos ha regalado de la noche a la mañana (esto no tiene precio):face-smile::face-devil-grin:
    De momento le he explicado el problema con el funcionamiento simultáneo del BT con el IMS.
  • Tendras que conectarte por telnet. Ejecutando el comando free veras si hay swap o no, que igual si que la han activado en el mod, no lo se.
    A mi, con el 739 me sale:

    f/ # free
    total used free shared buffers
    Mem: 120652 115520 5132 0 3756
    Swap: 32 0 32
    Total: 120684 115520 5164

    Eso quiere decir que hay 32 KB de swap, como si no hubiera nada vamos.

    No se puede ver de donde saca la swap porque el comando swapon es uno algo capado, no como el de linux, solo sirve para añadir mas dispositivos de swap.

    En mi sistema se puede añadir a la swap /dev/sda2, la segunda particion del disco duro, que es de 150MB. Para ver que particion esta formateada para swap, ejecuta fdisk -l /dev/sda. Esta es mi salida:

    Disk /dev/sda: 120.0 GB, 120034123776 bytes
    255 heads, 63 sectors/track, 14593 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot Start End Blocks Id System
    /dev/sda1 2 13961 112133700 7 HPFS/NTFS
    /dev/sda2 13962 13981 160650 82 Linux swap
    /dev/sda3 13982 14049 546210 83 Linux
    /dev/sda4 14050 14573 4209030 83 Linux

    Hay se ve que se puede usar /dev/sda2 como swap. Entonces ejecutas swapon /dev/sda2 y al ejecutar free veras que la swap ha aumentado.

    No se queda fijo, para eso habria que modificar el fichero /etc/fstab, pero esta en una particion de solo lectura asi que habria que modificar el firm.
  • edited enero 2011
    Si, sólo me salen 32 KB de swap. Nada que hacer.:face-crying:
    Cuando dices que no se queda fijo entiendo que habria que aumentarla ¿cada vez que ejecutara ambos procesos?. ¿en qué momento volvería a disminuir? ¿al apagar el hmr?

    PD: canales ordenados via web MHDW (DTV Web Channer Editor). Rápido y efectivo :face-devil-grin::face-devil-grin:
  • edited enero 2011
    No, me refiero al reiniciar. Cuando reiniciases volvería a tener 32KB. En el fichero /etc/fstab va donde debe montar cada particion, y ahí se dice tambien si hay que usar alguna particion para swap, como no sale nada sobre swap al reiniciar volvería a tener 32KB. Con el comando swapon añades a la swap una particion y se queda así hasta apagar o ejecutar swapoff.

    Prueba a aumentar con swapon y ver algo en youtube mientras descargas con el bittorrent, a ver si así no se cuelga. Si te funciona, lo suyo sería probar de nuevo sin swap a ver si realmente se cuelga para confirmar que lo de la swap lo ha arreglado y que no fue casualidad, si no que era debido a la falta de memoria.

    La swap se usa para que cuando se tienen varios procesos en marcha que usan mas memoria de la disponible, el que este parado se manda a la swap, que es escribirlo en el disco duro. Cuando le toca a ese proceso ejecutarse, se tiene que traer de la swap a memoria, probablemente mandando algo a swap de nuevo a no ser que se haya reducido el uso de memoria, por lo que el sistema se ralentiza algo al usar swap y no es conveniente usar demasiada.

    Y si no ya hare pruebas esta semana cuando tenga tiempo, ahora no me va bien.
  • edited enero 2011
    OK :face-smile:. Probaré a ver que pasa. Supongo que al estar basado en Linux es la misma lógica (memoria de intercambio)que se utiliza cuando se instala Ubuntu o cualquier otra distro y se deja una partición para la Swap con un mínimo tamaño para que el sistema funcione de forma más fluida.
    Durante un tiempo fuí bastante adicto a Ubuntu y a la consola de comandos, pero la inercia de Windows me volvió a atrapar. Ahora lo tengo como segundo SO pero casi no lo utilizo y he olvidado la mayoría de comandos. Habrá que retomarlo (estas cosas absorben mucho y yo ando mal de tiempo....:face-crying:).
    De todas formas gracias por la idea.
  • despues de unas horas pruebas he decidido volver al oficial, cada vez que apagaba y encendia hacia lo que queria y la mayorias de las veces se bloqueaba.

    El mando repondia algo lento, eso si el tener acceso por http al cacharro esta bien, pero prefiero que sea estable a tener pijaditas .... por ahora.

    Un saludo :face-devil-grin:
  • Si, es la misma logica, al fin y al cabo es memoria de intercambio y se usa para lo mismo en cualquier SO (no solo linux).
  • [cite] zzmarin:[/cite]despues de unas horas pruebas he decidido volver al oficial, cada vez que apagaba y encendia hacia lo que queria y la mayorias de las veces se bloqueaba.

    El mando repondia algo lento, eso si el tener acceso por http al cacharro esta bien, pero prefiero que sea estable a tener pijaditas .... por ahora.

    Un saludo :face-devil-grin:

    ¿A que mando te refieres? ¿al de la página web de acceso o al físico?. A mi me funciona bien, sin demora. ¿Qué firm instalaste? ¿el de Ellion o el de 4Geek?
    En mi caso el único bloqueo comprobado lo he notado al usar simultáneamente el BT con el IMS. Por lo demás no noto cosas raras, aunque puede que sea pronto para sacar conclusiones. Como novedad me parece una alternativa interesante (por lo menos soluciona el problema del BT, que para mi es de bastante utilidad).:face-angel:
  • edited febrero 2011
    [cite] enpijama:[/cite]No, me refiero al reiniciar. Cuando reiniciases volvería a tener 32KB. En el fichero /etc/fstab va donde debe montar cada particion, y ahí se dice tambien si hay que usar alguna particion para swap, como no sale nada sobre swap al reiniciar volvería a tener 32KB. Con el comando swapon añades a la swap una particion y se queda así hasta apagar o ejecutar swapoff.

    En el HMR no puedes activar la swap incluyéndola en /etc/fstab porque cuando se lee dicho fichero todavía no se ha cargado el driver sata-mars. De ahí que en /etc/fstab sólo aparezcan sistemas de ficheros virtuales y una de las particiones de la flash.

    Las particiones en el disco duro interno parece que se encarga de montarlas el DvdPlayer. Lo que no tengo claro es si lo hace porque no es seguro que haya disco duro (hay players que no lo incluyen y no es necesario para muchas cosas) o por alguna otra razón. Por ejemplo, creo que nuestro HMR no tiene bateria para mantener en funcionamiento el reloj, por lo que si se montan las particiones antes de sincronizar el reloj (con la TDT por poner un caso), las fechas de montaje de la partición y de acceso/escritura de los ficheros modificados estarían mal y cuando intentases comprobar errores en el disco te aparecerían seguro. Pero ya te digo que no lo tengo claro y nunca me he parado a mirar fechas de creación/acceso de los ficheros del disco interno.

    Saludos.
  • Es verdad, tienes razon, que el disco duro lo carga bastante tarde. Incluso da tiempo de ir a la configuracion para activar el bittorrent y no deja porque no ha cargado el disco duro.

    Sería cuestion de añadirlo donde arranquen por ejemplo el bittorrent en ese mod, si instalan los añadidos en el disco duro y se ejecutan solos en el arranque no debería ser muy dificil añadir el comando swapon. Pero primero hay que comprobar que el cuelgue fue provocado por falta de memoria y que se arregle con la swap.
  • Es posible que el fichero /usr/local/etc/rcS se encargue de montar el disco duro. Al final de ese fichero esta esta linea:
    echo 2 /tmp/hdd/volumes/HDD1/ > /sys/realtek_boards/misc_operations

    Podria ser que eso le mande montar las particiones, aunque imagino que le dara instrucciones de esperar a que este disponible y que luego lo monte. Quizas poniendo un sleep y un swapon se pueda añadir ahí, se podría probar, si ralentiza el arranque, por no terminar el proceso hasta hacer sleep, se podria hacer en background con &:
    (sleep 2; swapon /dev/sda2)&
    O un sleep mayor para estar seguros, 10, 15, no sé.
  • Otra cosa más, probablemente tambien se podria modificar ese fichero para montar una particion ext3 en lugar de usar ntfs por ejemplo
  • [cite] enpijama:[/cite]Es posible que el fichero /usr/local/etc/rcS se encargue de montar el disco duro. Al final de ese fichero esta esta linea:
    echo 2 /tmp/hdd/volumes/HDD1/ > /sys/realtek_boards/misc_operations

    Podria ser que eso le mande montar las particiones, aunque imagino que le dara instrucciones de esperar a que este disponible y que luego lo monte. Quizas poniendo un sleep y un swapon se pueda añadir ahí, se podría probar, si ralentiza el arranque, por no terminar el proceso hasta hacer sleep, se podria hacer en background con &:
    (sleep 2; swapon /dev/sda2)&
    O un sleep mayor para estar seguros, 10, 15, no sé.

    Referente a lo de ralentizar el arranque, comentar que con el mod instalando y funcionando, el arranque se demora bastante más que sin el.
  • [cite] enpijama:[/cite]Es posible que el fichero /usr/local/etc/rcS se encargue de montar el disco duro. Al final de ese fichero esta esta linea:
    echo 2 /tmp/hdd/volumes/HDD1/ > /sys/realtek_boards/misc_operations

    Creo que todos pensamos lo mismo. Lo mejor para confirmarlo definitivamente sería encontrar el código encargado de ejecutar dicha "orden".
  • edited febrero 2011
    [cite] tatanka:[/cite]
    Referente a lo de ralentizar el arranque, comentar que con el mod instalando y funcionando, el arranque se demora bastante más que sin el.

    El firmware modificado se ejecuta en su mayor parte en el disco duro por lo que tiene que esperar a que este esté disponible. Además, tiene que comprobar más cosas y, por si esto no fuera suficiente, se ha intentado hacerlo compatible con diferentes situaciones y creo que se ha optado más por añadir muchas cosas más que por hacerlo de la forma más eficiente. Por ejemplo, se instala un nuevo servidor web (lighttpd) pero, sin embargo, a su vez se sigue usando el aportado por Busybox, con lo que se usa más memoria y no sé dónde está el beneficio (se ahorra algo de espacio en el disco, pero...). Luego está el tema de poner las librerías en diferentes carpetas, lo cual está muy bien para tener todo separado (programa + librerías en una carpeta aparte), pero luego te perjudica porque tienes que añadir todas esas carpetas al PATH de búsqueda que se usa para encontrar las librerías, haciendo el proceso más lento. Y así, alguna cosa más. Si alguien quiere optimizarlo para que vaya más rápido, aun a costa de perder algo de compatibilidad y algún programa por el camino, margen tiene.

    Saludos.
  • Además como acabo de comentarle a Chucky, el IMS también está mejorado con respecto al firm original, pero claro, sin el menú desarrollado por Chucky :face-crying:. Habría que adaptarlo/añadirlo para poder tenerlo accesible dentro de este mod..........
  • Como curiosidad he desactivado el IPKG y he instalado el Menu IMS 3.1 de Chucky para verificar si funcionaba o no. Con el IPKG desactivado he sobreescrito su menu.rss con el nuestro y efectivamente aparece el menú de Chucky totalmente operativo. Por supuesto el anterior ha desaparecido al sobreescribir.
    Pensando que al activar el IPKG sobre esta modificación me respetaría el cambio realizado, mi sorpresa ha sido ver que una vez vuelto a activar el IPKG desaparece el menú de Chucky y aparece nuevamente el anterior. Por lo visto debe de restaurar el archivo menu.rss desde algún sitio y sobreescribir el que yo he puesto :face-plain:
  • El IPKG lo que instala es una imagen de disco (como las ISO sacadas de los CDs o DVDs pero con un sistema de ficheros ext3). De ahí es de donde restaura su menú y todo lo demás. Si quieres hacer tus cambios permanentes debes modificar dicha imagen. Y para asegurarte de que todo va a funcionar como quieres, también debes comprender el funcionamiento del mod y los scripts que usa.

    Saludos.
  • ¿He? Pues eso ya no me mola:face-sad:

    Si alguno mas lo prueba que comente.
Accede o Regístrate para comentar.